Gönderen Konu: Audacity, Kino, Xvidcap çalışmıyor! (çözüldü)  (Okunma sayısı 6185 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı AzerRail

  • Katkıcı Üye
  • ***
  • İleti: 196
  • Linuks diyorum başka bir nen demiyorum !
    • AzerRail'in Masaüstü
Audacity, Kino, Xvidcap çalışmıyor! (çözüldü)
« : 07 Haziran 2009, 11:22:37 ös »
Audacity, Kino, Xvidcap
Bu 3 uygulamayı da kurdum ama 3'de açılmadı bile...

gtk-dercorMyDesktop yazılımını da kurdum ama görüntüyü kaydetme sırasında hata veriyor sürekli...
« Son Düzenleme: 10 Haziran 2009, 06:13:32 ös Gönderen: AzerRail »

Çevrimdışı AzerRail

  • Katkıcı Üye
  • ***
  • İleti: 196
  • Linuks diyorum başka bir nen demiyorum !
    • AzerRail'in Masaüstü
Ynt: Audacity, Kino, Xvidcap çalışmıyor!
« Yanıtla #1 : 08 Haziran 2009, 05:33:02 ös »
avidemux yazılımını da kurdum.
Ama tıklıyoruz, daha başlamıyorlar bile. Sanırım bu tür uygulamalar için gerekli bir başka bağımlılık var.

Çevrimdışı atlantis

  • Yönetici
  • Forum Gurusu
  • *****
  • İleti: 600
  • Truva Linux
    • Truva Linux
Ynt: Audacity, Kino, Xvidcap çalışmıyor!
« Yanıtla #2 : 08 Haziran 2009, 10:42:03 ös »
bağımlılık sorunlarını çözmek için programı konsoldan çalıştırmayı deneyeceksin. Sana orda verdiği hata çıktısı bağımlılık ipucunu verir zaten.

Çevrimdışı AzerRail

  • Katkıcı Üye
  • ***
  • İleti: 196
  • Linuks diyorum başka bir nen demiyorum !
    • AzerRail'in Masaüstü
Ynt: Audacity, Kino, Xvidcap çalışmıyor!
« Yanıtla #3 : 10 Haziran 2009, 12:13:13 ös »
Kod: [Seç]
root@darkstar:~# audacity
audacity: error while loading shared libraries: libwx_gtk2u_richtext-2.8.so.0: cannot open shared object file: No such file or directory
root@darkstar:~# avidemux
-bash: avidemux: command not found
root@darkstar:~# xvidcap
xvidcap: error while loading shared libraries: libmp3lame.so.0: cannot open shared object file: No such file or directory
root@darkstar:~#

Ne yapmam gerek?

Çevrimdışı atlantis

  • Yönetici
  • Forum Gurusu
  • *****
  • İleti: 600
  • Truva Linux
    • Truva Linux
Ynt: Audacity, Kino, Xvidcap çalışmıyor!
« Yanıtla #4 : 10 Haziran 2009, 12:17:11 ös »
Gslapt penceresini açtığında bir paket seç ve altta ki sekmelerde Bağımlılıklar sekmesini incele. Orda paketin çalışması için gereken paketleri listeler.

Eğer pakette slack-required dosyası varsa Gslapt sana o bağımlılıkları paket kurarken söylüyor zaten.

Ben bu seferlik sana gereken paket bağımlılıklarını veriyorum. Bundan sonra dediğim şekilde takip edersen sıkıntıların en aza iner.

audacity:
alsa-lib >= 1.0.15-i486-1
atk >= 1.22.0-i486-1
cairo >= 1.4.14-i486-1
cxxlibs >= 6.0.9-i486-1 | gcc-g++ >= 4.2.3-i486-1
expat >= 2.0.1-i486-1
flac >= 1.2.1-i486-1
fontconfig >= 2.4.2-i486-2
freetype >= 2.3.5-i486-1
gcc >= 4.2.3-i486-1
glib2 >= 2.14.6-i486-4
glibc-solibs >= 2.7-i486-10
gtk+2 >= 2.12.9-i486-1
jack-audio-connection-kit >= 0.109.2-i486-2sl
libICE >= 1.0.4-i486-1
libSM >= 1.0.3-i486-1
libX11 >= 1.1.4-i486-1
libXau >= 1.0.3-i486-1
libXcomposite >= 0.4.0-i486-1
libXcursor >= 1.1.9-i486-1
libXdamage >= 1.1.1-i486-1
libXdmcp >= 1.0.2-i486-1
libXext >= 1.0.4-i486-1
libXfixes >= 4.0.3-i486-1
libXi >= 1.1.3-i486-1
libXinerama >= 1.0.3-i486-1
libXrandr >= 1.2.2-i486-1
libXrender >= 0.9.4-i486-1
libXxf86vm >= 1.0.1-i486-1
libid3tag >= 0.15.1b-i486-2
libjpeg >= 6b-i486-5
libmad >= 0.15.1b-i486-3
libmspack >= 0.0.20060920alpha-i486-1as
libogg >= 1.1.3-i486-2
libpng >= 1.2.27-i486-1
libsndfile >= 1.0.17-i486-1sl
libtiff >= 3.8.2-i486-3
libvorbis >= 1.2.0-i486-1
libxcb >= 1.0-i486-2
pango >= 1.20.0-i486-1
twolame >= 0.3.12-i486-1as
wxwidgets >= 2.8.9.unicode-i486-1sl
zlib >= 1.2.3-i486-2



xvidcap:
atk >= 1.22.0-i486-1
cairo >= 1.4.14-i486-1
dbus >= 1.1.20-i486-1
dbus-glib >= 0.74-i486-2
expat >= 2.0.1-i486-1
fontconfig >= 2.4.2-i486-2
freetype >= 2.3.5-i486-1
glib2 >= 2.14.6-i486-4
glibc-solibs >= 2.7-i486-10
gtk+2 >= 2.12.9-i486-1
lame >= 3.98-i486-1sl
libICE >= 1.0.4-i486-1
libSM >= 1.0.3-i486-1
libX11 >= 1.1.4-i486-1
libXau >= 1.0.3-i486-1
libXcomposite >= 0.4.0-i486-1
libXcursor >= 1.1.9-i486-1
libXdamage >= 1.1.1-i486-1
libXdmcp >= 1.0.2-i486-1
libXext >= 1.0.4-i486-1
libXfixes >= 4.0.3-i486-1
libXi >= 1.1.3-i486-1
libXinerama >= 1.0.3-i486-1
libXmu >= 1.0.4-i486-1
libXrandr >= 1.2.2-i486-1
libXrender >= 0.9.4-i486-1
libXt >= 1.0.5-i486-1
libglade >= 2.6.2-i486-2
libpng >= 1.2.27-i486-1
libxcb >= 1.0-i486-2
libxml2 >= 2.6.31-i486-2
pango >= 1.20.0-i486-1
zlib >= 1.2.3-i486-2



Bu bağımlılıkların çoğu zaten sisteminde kuruludur. Bazılarının güncellenmesine ihtiyaç duyulabilir.

Çevrimdışı AzerRail

  • Katkıcı Üye
  • ***
  • İleti: 196
  • Linuks diyorum başka bir nen demiyorum !
    • AzerRail'in Masaüstü
Ynt: Audacity, Kino, Xvidcap çalışmıyor!
« Yanıtla #5 : 10 Haziran 2009, 02:12:27 ös »
Şimdi bu bağımlılıları tek tek bulup kuracak mıyım. Yoksa bir komut ile tümü kurulabilir mi?

Çevrimdışı atlantis

  • Yönetici
  • Forum Gurusu
  • *****
  • İleti: 600
  • Truva Linux
    • Truva Linux
Ynt: Audacity, Kino, Xvidcap çalışmıyor!
« Yanıtla #6 : 10 Haziran 2009, 02:14:40 ös »
Eğer bağımlılık kontrolü sağlayan bir altyapımız olsa bu paketlerin kurulu olup olmadığına bakar olmayanları bağımlılıkları ile beraber kurardı. Biz de bu işler elle yapılmak zorunda şu anda.

Daha öncede dediğim gibi sistemde bahsi geçen bir çok program kuruludur. Sen sadece kurulu olmayanları bulup kuracaksın.

Çevrimdışı AzerRail

  • Katkıcı Üye
  • ***
  • İleti: 196
  • Linuks diyorum başka bir nen demiyorum !
    • AzerRail'in Masaüstü
Ynt: Audacity, Kino, Xvidcap çalışmıyor! (çözüldü)
« Yanıtla #7 : 10 Haziran 2009, 06:14:47 ös »
xvidcap için "lame >= 3.98-i486-1sl" paketi kurulu değilmiş, onu kurunca çalıştı.
Öbür yazılımlara da zamanım olunca bakacağım.

Aslında bunu kendisi yapsa çok iyi olur. Bu özelliği eklemek için çalışma var mı peki?

Çevrimdışı atlantis

  • Yönetici
  • Forum Gurusu
  • *****
  • İleti: 600
  • Truva Linux
    • Truva Linux
Ynt: Audacity, Kino, Xvidcap çalışmıyor! (çözüldü)
« Yanıtla #8 : 10 Haziran 2009, 06:16:12 ös »
Yeni paket yönetim sistemi gelirse olması gerekenlerin başında bu geliyor.